Dispatch Mobile App - Service Degradation for Some Regions
Resolved
Feb 04 at 07:06pm EST
The domain access issue has been resolved. Our domain was inadvertently blocked on the T-Mobile network, and the restriction has now been lifted. Service should be fully accessible for T-Mobile users.
Affected services
Updated
Feb 04 at 05:58pm EST
The issue has been isolated to users on the T-Mobile Cellular Network via a DNS resolution error. We are actively working towards a resolution. In the meantime, please use Wi-Fi when available
Affected services
Created
Feb 04 at 04:54pm EST
Some authentication issues starting earlier today, Feb 4th, 2026. Triage and root-cause determination in progress.
Affected services