Back to overview

Search degradation in Impound and Vehicle Finder

Apr 16, 2026 at 5:06pm UTC
Affected services
aries.autoreturn.com/impound

Resolved
Apr 16, 2026 at 6:54pm UTC

Search issues have now been resolved.

Created
Apr 16, 2026 at 5:06pm UTC

We have identified an issue causing some search issues for vehicles modified within the last 9 hours